|
Home | Switchboard | Unix Administration | Red Hat | TCP/IP Networks | Neoliberalism | Toxic Managers |
(slightly skeptical) Educational society promoting "Back to basics" movement against IT overcomplexity and bastardization of classic Unix |
|
svmon
svmon -P <pid>
Further: use can user svmon command to monitor memory usage as follows;
(A) #svmon -P -v -t 10 | more (will give top ten processes)
(B) #svmon -U -v -t 10 | more ( will give top ten user)
|
smit install requires "inutoc ." first. It'll autogenerate a .toc for
you
I believe, but if you later add more .bff's to the same directory, then
the inutoc . becomes important. It is of course, a table of contents.
<Michael_Abel/resnova%[email protected]> As root: bootinfo -r As any user: lsattr -E -l sys0 -a realmem lsdev -C -c memory shows all memory adapters. On MCA systems one may add up the values displayed for each memory card in order to sum up to the amount of total memory. On PCI systems only one item (mem0) is displayed. Additional information may be displayed with lsattr -E -lmem0 These commands were tested on various IBM systems running AIX relases 3.2.5 and 4.1.4
You can set the initial priority of a process to a value lower than the base scheduling priority.To set the initial priority of a process to a value lower than the base scheduling priority, use the nice command to start the process.
Note: To run a process at a higher priority than the base scheduling priority, you must have root user authority.To set the initial priority of a process, type the following:
nice -n Number CommandString
where Number is in the range of 0 to 39, with 39 being the lowest priority. The nice value is the decimal value of the system-scheduling priority of a process. The higher the number, the lower the priority. If you use zero, the process will run at its base scheduling priority. CommandString is the command and flags and parameters you want to run.See the nice command in the AIX 5L Version 5.3 Commands Reference, Volume 4 for the complete syntax.
You can also use the smit nice command to perform this task.
Parent topic: Processes
COMMAND | PARAMETER | DESCRIPTION |
bootlist | -m normal <dev1> <dev2> | Alters the list of boot devices (or the ordering of these devices in the list available to the system) |
bosboot | -a
-ad /dev/rnt<x> -b <loc of bootimage> |
Create a boot image
on the default boot device Create a boot image at location and send to tape |
cfgmgr | Configures devices by running the programs in /etc/methods directory. | |
chcons | Redirects the system console to device or file, effective next startup | |
chdev | -l <device> -a<params> | Changes a device's characteristics. |
chdisp | Changes the display used by the low-function terminal (LFT subsystem. | |
chfont | Changes the default font selected at boot time. | |
chfs | -a size=+<blocks> /<FS> | Changes attributes of a file system. This one will increase the Filesystem . |
chgroup | Users=x,y,z <grp name> | Changes attributes for groups. |
chlv | -n <nlvname> <olvname> | Rename logical volume from olvname to nlvname |
chps | -s<no. pps> <ps name> | Changes attributes of a paging space. |
chpv | Changes the characteristics of a physical volume in a volume group. | |
chque | -q<q name> -a'host = x' | Changes the queue name. |
chssys | Changes a subsystem definition in the subsystem object class. | |
chtcb | Changes or queries the trusted computing base attribute of a file. | |
chtz. | Changes the system time zone information | |
chuser | rlogin=true <username> | Changes attributes for the specified user. |
chvfs | Changes entries in the /etc/vfs file. | |
chvg | Sets the characteristics of a volume group. | |
crfs | -v <fstype> (jfs)
-d <lvname> -m <mount point> -Ayes |
Create a Filesystem on a pre-defined logical volume( which will automount at boot!) |
crfs | -v <fstype> (jfs)
-g <vgname> -a size='<no blocks>' -m <mount point> -Ayes |
Create a Filesystem and its logical volume (uses default lvname) |
crvfs | Creates entries in the /etc/vfs file. | |
exportvg | None | Export a volume group |
grpck | -n ALL | Verifies the correctness of a group definition. |
hvirprt | Changes the attribute values of a virtual printer. | |
importvg | -y <vgname>
<hdisk x> |
Import a Volume Group onto hdisk x |
lpstat | List print queues | |
lsallq | Lists the names of all configured queues. | |
lsallqdev | Lists all configured printer and plotter queue device names within a specified queue. | |
lsattr | -El <devname> | List detailed configuration for a device |
lscfg | List all configured devices | |
-v | List in detail | |
-l scsi* | List all scsi IO devices | |
lsdev | -Cc tape | List configured tape devices |
-Cc disk | List configured disks on devices | |
-C -s scsi -H | List all defined scsi devices | |
lsdisp | Lists the displays currently available on the system. | |
lsfont | Lists the fonts available for use by the display. | |
lsfs | -l | List all filesystems in /etc/filesystems quering the LVM descriptor area and superblocks |
lsfs | Displays the characteristics of file systems. | |
lsgroup | ALL | Displays the attributes of groups.(checks NIS aswell!) |
lsitab | -a | Lists the records in the /etc/inittab file. |
lskbd | Lists the keyboard maps currently available to the low-function terminal (LFT subsystem. | |
lslicense | Displays the number of fixed licenses and the status of floating licensing. | |
lslpp | -l | List all installed software |
lslv | <lvname> | List configuration details of a given Logical Volume |
-l <lvname> | List further configuration details of a given disk | |
lsprtsv | -ch | Shows print service information stored in the database. |
lsps | -a | List pagaing space |
lspv | None | List configured disks |
<hdisk> | List configuration details of a given disk | |
-l <hdisk> | List Logical Volumes/Filesystems on a given disk | |
lsque | Displays the queue stanza name. | |
lsquedev | Displays the device stanza name. | |
lssrc | -a | List all subsystems |
lsuser | Displays attributes of user accounts. | |
lsvfs | Lists entries in the /etc/vfs file. | |
lsvg | None | List configured Volume groups |
<vgname> | List configuration details of a given Volume group | |
-l <vgname> | List Logical Volumes/Filesystems on a given Volume Group | |
mkcatdefs | Preprocesses a message source file. | |
mkdev | Adds a device to the system. | |
mkfont | Adds the font code associated with a display to the system. | |
mkfontdir | Creates a fonts.dir file from a directory of font files. | |
mkgroup | Creates a new group. | |
mkitab | Makes records in the /etc/inittab file. | |
mklv | -y <lvname>
<vgname> <no of pps> |
Create a Logical Volume |
mklv | Creates a logical volume. | |
mklvcopy | Adds copies to a logical volume. | |
mknamsv | Configures TCP/IP-based name service on a host for a client. | |
mknotify | Adds a notify method definition to the notify object class. | |
mkprtsv | Configures TCP/IP-based print service on a host. | |
mkps | Add an additional paging space to the system. | |
mkque | Adds a printer queue to the system. | |
mkquedev | Adds a printer queue device to the system. | |
mkserver | Adds a subserver definition to the subserver object class. | |
mkssys | Adds a subsystem definition to the subsystem object class. | |
mksysb. | Backs up mounted file systems in the rootvg volume group for subsequent reinstallation | |
mkszfile. | Records size of mounted file systems in the rootvg volume group for reinstallation | |
mktcpip | Sets the required values for starting TCP/IP on a host. | |
mkuser | Creates a new user account. | |
mkuser.sys | Customizes a new user account. | |
Mkvg | -y <vgname> -s <ppsize> <hdisk x> |
Create a Volume Group on hdisk x |
mkvg | Creates a volume group. | |
mkvirprt | Makes a virtual printer. | |
odmadd | Adds objects to created object classes. | |
odmchange | Changes the contents of a selected object in the specified object class. | |
odmcreate | Produces the .c (source and .h (include files necessary for ODM application development and creates empty objectclasses. | |
odmdelete | Deletes selected objects from a specified object class. | |
odmdrop | Removes an object class. | |
odmget | Retrieves objects from the specified object classes and places them into an odmadd input file. | |
odmshow | Displays an object class definition on the screen. | |
pwdck | Verifies the correctness of local authentication information. | |
redefinevg | Redefines the set of physical volumes of the given volume group in the device configuration database. | |
reducevg | Removes physical volumes from a volume group. When all physical volumes are removed from the volume group, the volume group is deleted. | |
reorgvg | Reorganizes the physical partition allocation for a volume group. | |
restbase | Restores customized information from the boot image. | |
rmdel | Removes a delta from a Source Code Control System (SCCS file. | |
rmdev | Removes a device from the system. | |
rmf | Removes folders and the messages they contain. | |
rmfs | Removes a file system. | |
rmgroup | Removes a group. | |
rmitab | Removes records in the /etc/inittab file. | |
rmlv | Removes logical volumes from a volume group. | |
rmlvcopy | Removes copies from a logical volume. | |
rmm | Removes messages. | |
rmnamsv | Unconfigures TCP/IP-based name service on a host. | |
rmnotify | Removes a notify method definition from the notify object class. | |
rmprtsv | Unconfigures a print service on a client or server machine. | |
rmps | Removes a paging space from the system. | |
rmque | Removes a printer queue from the system. | |
rmquedev | Removes a printer or plotter queue device from the system. | |
rmserver | Removes a subserver definition from the subserver object class. | |
rmssys | Removes a subsystem definition from the subsystem object class. | |
rmuser | Removes a user account. | |
rmvfs | Removes entries in the /etc/vfs file. | |
rmvirprt | Removes a virtual printer. | |
runcat | Pipes the output data from the mkcatdefs command to the gencat command. | |
savebase | Saves base customized device data in the ODM onto the boot device. | |
startsrc | -s <subsystem> | Start a subsystem |
stopsrc | -s <subsystem> | Stop a subsystem |
syncvg | Synchronizes logical volume copies that are not current. | |
usrck | Verifies the correctness of a user definition. | |
varyoffvg | <vgname> | Takes a Volume Group offline |
varyoffvg | Deactivates a volume group. | |
varyonvg | <vgname> | Puts a Volume Group online |
varyonvg | Activates a volume group. |
Quick Reference Solaris to AIX
Transition from Solaris to AIX
Society
Groupthink : Two Party System as Polyarchy : Corruption of Regulators : Bureaucracies : Understanding Micromanagers and Control Freaks : Toxic Managers : Harvard Mafia : Diplomatic Communication : Surviving a Bad Performance Review : Insufficient Retirement Funds as Immanent Problem of Neoliberal Regime : PseudoScience : Who Rules America : Neoliberalism : The Iron Law of Oligarchy : Libertarian Philosophy
Quotes
War and Peace : Skeptical Finance : John Kenneth Galbraith :Talleyrand : Oscar Wilde : Otto Von Bismarck : Keynes : George Carlin : Skeptics : Propaganda : SE quotes : Language Design and Programming Quotes : Random IT-related quotes : Somerset Maugham : Marcus Aurelius : Kurt Vonnegut : Eric Hoffer : Winston Churchill : Napoleon Bonaparte : Ambrose Bierce : Bernard Shaw : Mark Twain Quotes
Bulletin:
Vol 25, No.12 (December, 2013) Rational Fools vs. Efficient Crooks The efficient markets hypothesis : Political Skeptic Bulletin, 2013 : Unemployment Bulletin, 2010 : Vol 23, No.10 (October, 2011) An observation about corporate security departments : Slightly Skeptical Euromaydan Chronicles, June 2014 : Greenspan legacy bulletin, 2008 : Vol 25, No.10 (October, 2013) Cryptolocker Trojan (Win32/Crilock.A) : Vol 25, No.08 (August, 2013) Cloud providers as intelligence collection hubs : Financial Humor Bulletin, 2010 : Inequality Bulletin, 2009 : Financial Humor Bulletin, 2008 : Copyleft Problems Bulletin, 2004 : Financial Humor Bulletin, 2011 : Energy Bulletin, 2010 : Malware Protection Bulletin, 2010 : Vol 26, No.1 (January, 2013) Object-Oriented Cult : Political Skeptic Bulletin, 2011 : Vol 23, No.11 (November, 2011) Softpanorama classification of sysadmin horror stories : Vol 25, No.05 (May, 2013) Corporate bullshit as a communication method : Vol 25, No.06 (June, 2013) A Note on the Relationship of Brooks Law and Conway Law
History:
Fifty glorious years (1950-2000): the triumph of the US computer engineering : Donald Knuth : TAoCP and its Influence of Computer Science : Richard Stallman : Linus Torvalds : Larry Wall : John K. Ousterhout : CTSS : Multix OS Unix History : Unix shell history : VI editor : History of pipes concept : Solaris : MS DOS : Programming Languages History : PL/1 : Simula 67 : C : History of GCC development : Scripting Languages : Perl history : OS History : Mail : DNS : SSH : CPU Instruction Sets : SPARC systems 1987-2006 : Norton Commander : Norton Utilities : Norton Ghost : Frontpage history : Malware Defense History : GNU Screen : OSS early history
Classic books:
The Peter Principle : Parkinson Law : 1984 : The Mythical Man-Month : How to Solve It by George Polya : The Art of Computer Programming : The Elements of Programming Style : The Unix Hater’s Handbook : The Jargon file : The True Believer : Programming Pearls : The Good Soldier Svejk : The Power Elite
Most popular humor pages:
Manifest of the Softpanorama IT Slacker Society : Ten Commandments of the IT Slackers Society : Computer Humor Collection : BSD Logo Story : The Cuckoo's Egg : IT Slang : C++ Humor : ARE YOU A BBS ADDICT? : The Perl Purity Test : Object oriented programmers of all nations : Financial Humor : Financial Humor Bulletin, 2008 : Financial Humor Bulletin, 2010 : The Most Comprehensive Collection of Editor-related Humor : Programming Language Humor : Goldman Sachs related humor : Greenspan humor : C Humor : Scripting Humor : Real Programmers Humor : Web Humor : GPL-related Humor : OFM Humor : Politically Incorrect Humor : IDS Humor : "Linux Sucks" Humor : Russian Musical Humor : Best Russian Programmer Humor : Microsoft plans to buy Catholic Church : Richard Stallman Related Humor : Admin Humor : Perl-related Humor : Linus Torvalds Related humor : PseudoScience Related Humor : Networking Humor : Shell Humor : Financial Humor Bulletin, 2011 : Financial Humor Bulletin, 2012 : Financial Humor Bulletin, 2013 : Java Humor : Software Engineering Humor : Sun Solaris Related Humor : Education Humor : IBM Humor : Assembler-related Humor : VIM Humor : Computer Viruses Humor : Bright tomorrow is rescheduled to a day after tomorrow : Classic Computer Humor
The Last but not Least Technology is dominated by two types of people: those who understand what they do not manage and those who manage what they do not understand ~Archibald Putt. Ph.D
Copyright © 1996-2021 by Softpanorama Society. www.softpanorama.org was initially created as a service to the (now defunct) UN Sustainable Development Networking Programme (SDNP) without any remuneration. This document is an industrial compilation designed and created exclusively for educational use and is distributed under the Softpanorama Content License. Original materials copyright belong to respective owners. Quotes are made for educational purposes only in compliance with the fair use doctrine.
FAIR USE NOTICE This site contains copyrighted material the use of which has not always been specifically authorized by the copyright owner. We are making such material available to advance understanding of computer science, IT technology, economic, scientific, and social issues. We believe this constitutes a 'fair use' of any such copyrighted material as provided by section 107 of the US Copyright Law according to which such material can be distributed without profit exclusively for research and educational purposes.
This is a Spartan WHYFF (We Help You For Free) site written by people for whom English is not a native language. Grammar and spelling errors should be expected. The site contain some broken links as it develops like a living tree...
|
You can use PayPal to to buy a cup of coffee for authors of this site |
Disclaimer:
The statements, views and opinions presented on this web page are those of the author (or referenced source) and are not endorsed by, nor do they necessarily reflect, the opinions of the Softpanorama society. We do not warrant the correctness of the information provided or its fitness for any purpose. The site uses AdSense so you need to be aware of Google privacy policy. You you do not want to be tracked by Google please disable Javascript for this site. This site is perfectly usable without Javascript.
Last modified: March 12, 2019