|
Home | Switchboard | Unix Administration | Red Hat | TCP/IP Networks | Neoliberalism | Toxic Managers |
(slightly skeptical) Educational society promoting "Back to basics" movement against IT overcomplexity and bastardization of classic Unix |
Admittedly, a list such as this can be helpful in quickly answering some of your own questions. However, it does not cover everything that you might need. You can extend the usefulness of such a list by adding other commands that answer additional questions not addressed here.
As you know, AIX has a vast array of commands that enable you to do a multitude of tasks. Depending on what you need to accomplish, you use only a certain subset of these commands. These subsets differ from user to user and from need to need. However, there are a few core commands that are commonly used. You need these commands either to answer your own questions or to provide answers to the support queries of professionals.
In this article, I'll discuss some of these core commands. The intent is to provide a list that you can use as a ready reference. While the behavior of these commands should be identical in all releases of AIX, they have been only tested under AIX 5.3.
uname -M
: This example provides the type and model
name. uname -L
: This example demonstrates the logical partitions
(LPAR) number and LPAR name. uname -m
: This example generates the machine sequence
number (obsolete). We do not recommend it because it does not always
uniquely identify a system. The serial number also is contained in the output from lscfg -vp
lsattr -El sys0 # Look for the 'systemid' toward the bottom.
How do I know if I'm running a uniprocessor kernel or multiprocessor kernel?
/unix is a symbolic link to the booted kernel. To find out what kernel mode is running, enter ls -l /unix and see what file /unix it links to. The following are the three possible outputs from the ls -l /unix command and their corresponding kernels (Note: AIX 5L Version 5.3 doesn't support a uniprocessor kernel.):
/unix -> /usr/lib/boot/unix_up # 32 bit uniprocessor kernel
/unix -> /usr/lib/boot/unix_mp # 32 bit multiprocessor kernel
/unix -> /usr/lib/boot/unix_64 # 64 bit multiprocessor kernel
How can I change from one kernel mode to another?
During the installation process, one of the kernels, appropriate for the AIX version and the hardware in operation, is enabled by default. Let's use the method from the previous question and assume the 32-bit kernel is enabled. Let's also assume that you want to boot it up in the 64-bit kernel mode. This can be done by executing the following commands in sequence:
ln -sf /usr/lib/boot/unix_64 /unix
ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
bosboot -ad /dev/hdiskxx
shutdown -r
The /dev/hdiskxx directory is where the boot logical volume /dev/hd5 is located. To find out what xx is in hdiskxx, run the following command:
lslv -m hd5
In AIX 5.2, the 32-bit kernel is installed by default. In AIX 5.3, the 64-bit kernel is installed on 64-bit hardware and the 32-bit kernel is installed on 32-bit hardware by default.
HardwareHow do I know if my machine is capable of running AIX 5L Version 5.3?
AIX 5L Version 5.3 runs on all currently supported Common Hardware Reference Platform (CHRP)-based POWER hardware.How do I know if my machine is CHRP-based?
Run the prtconf command. If it's a CHRP machine, the string chrp appears on the Model Architecture line.How do I know if my pSeries machine (hardware) is 32-bit or 64-bit?
To display if the hardware is 32-bit or 64-bit, enter:bootinfo -y
How much real memory does my machine have?To display real memory in KB, type one of the following:
bootinfo -rCan my machine run the 64-bit kernel?lsattr -El sys0 -a realmem
64-bit hardware is required to run the 64-bit kernel.
What are the values of the attributes for devices in my system?To list the current values of the attributes for the tape device, rmt0, enter:
How would I know if I am running a 32-bit kernel or 64-bit kernel?
To display if the kernel is 32-bit enabled or 64-bit enabled, type:
bootinfo -K
How do I know if I am running a uniprocessor kernel or a multiprocessor kernel?
/unix
is a symbolic link to the booted kernel. To find out
what kernel mode is running, enter ls -l /unix
and see what
file /unix
it links to. The following are the three possible
outputs from the ls -l /unix
command and their corresponding
kernels:
/unix -> /usr/lib/boot/unix_up # 32 bit uniprocessor kernel /unix -> /usr/lib/boot/unix_mp # 32 bit multiprocessor kernel /unix -> /usr/lib/boot/unix_64 # 64 bit multiprocessor kernel
Note: AIX 5L Version 5.3 does not support a uniprocessor kernel.
How can I change from one kernel mode to another?
During the installation process, one of the kernels, appropriate for the AIX version and the hardware in operation, is enabled by default. Let us use the method from the previous question and assume the 32-bit kernel is enabled. Let us also assume that you want to boot it up in the 64-bit kernel mode. This can be done by executing the following commands in sequence:
ln -sf /usr/lib/boot/unix_64 /unix
ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
bosboot -ad /dev/hdiskxx shutdown -r
The /dev/hdiskxx directory is where the boot logical volume /dev/hd5 is located. To find out what xx is in hdiskxx, run the following command:
lslv -m hd5Note: In AIX 5.2, the 32-bit kernel is installed by default. In AIX 5.3, the 64-bit kernel is installed on 64-bit hardware and the 32-bit kernel is installed on 32-bit hardware by default.
How would I know if my machine is capable of running AIX 5L Version 5.3?
AIX 5L Version 5.3 runs on all currently supported CHRP (Common Hardware Reference Platform)-based POWER hardware.
How would I know if my machine is CHRP-based?
Run the prtconf
command. If it's a CHRP machine, the string
chrp
appears on the Model Architecture line.
How would I know if my System p machine (hardware) is 32-bit or 64-bit?
To display if the hardware is 32-bit or 64-bit, type:
bootinfo -y
How much real memory does my machine have?
To display real memory in kilobytes (KB), type one of the following:
lsattr -El sys0 -a realmem
Can my machine run the 64-bit kernel?
64-bit hardware is required to run the 64-bit kernel.
What are the values of attributes for devices in my system?
To list the current values of the attributes for the tape device, rmt0, type:
lsattr -l rmt0 -E
To list the default values of the attributes for the tape device, rmt0, type:
lsattr -l rmt0 -D
To list the possible values of the login attribute for the TTY device, tty0, type:
lsattr -l tty0 -a login -R
To display system level attributes, type:
lsattr -E -l sys0
How many processors does my system have?
To display the number of processors on your system, type:
lscfg | grep proc
How many hard disks does my system have and which ones are in use?
To display the number of hard disks on your system, type:
lspv
How do I list information about a specific physical volume?
To find details about hdisk1, for example, run the following command:
lspv hdisk1
How do I get a detailed configuration of my system?
Type the following:
lscfg
The following options provide specific information:
-p |
Displays platform-specific device information. The flag is applicable to AIX 4.2.1 or later. |
-v |
Displays the VPD (Vital Product Database) found in the customized VPD object class. |
For example, to display details about the tape drive, rmt0, type:
lscfg -vl rmt0
You can obtain very similar information by running the prtconf
command.
How do I find out the chip type, system name, node name, model number, and so forth?
The uname
command provides details about your system.
uname -p |
Displays the chip type of the system. For example, PowerPC. |
uname -r |
Displays the release number of the operating system. |
uname -s |
Displays the system name. For example, AIX. |
uname -n |
Displays the name of the node. |
uname -a |
Displays the system name, nodename, version, machine ID. |
uname -M |
Displays the system model name. For example, IBM, 9114-275. |
uname -v |
Displays the operating system version. |
uname -m |
Displays the machine ID number of the hardware running the system. |
uname -u |
Displays the system ID number. |
What version, release, and maintenance level of AIX is running on my system?
Type one of the following:
oslevel -r
lslpp -h bos.rte
How can I determine which fileset updates are missing from a particular AIX level?
To determine which fileset updates are missing from 5300-04, for example, run the following command:
>oslevel -rl 5300-04
What SP (Service Pack) is installed on my system?
To see which SP is currently installed on the system, run the oslevel
-s
command. Sample output for an AIX 5L Version 5.3 system, with
TL4, and SP2 installed would be:
oslevel -s 5300-04-02
Is a CSP (Concluding Service Pack) installed on my system?
To see if a CSP is currently installed on the system, run the oslevel
-s
command. Sample output for an AIX 5L Version 5.3 system, with
TL3, and CSP installed would be:
oslevel -s 5300-03-CSP
How do I create a file system?
The following command will create, within volume group testvg, a jfs file system of 10MB with mounting point /fs1:
crfs -v jfs -g testvg -a size=10M -m /fs1
The following command will create, within volume group testvg, a jfs2 file system of 10MB with mounting point /fs2 and having read only permissions:
crfs -v jfs2 -g testvg -a size=10M -p ro -m /fs2
How do I change the size of a file system?
To increase the /usr
file system size by 1000000 512-byte
blocks, type:
chfs -a size=+1000000 /usr
Note:
In AIX 5.3, the size of a JFS2 file system can be shrunk as well.
How do I mount a CD?
Type the following:
mount -V cdrfs -o ro /dev/cd0 /cdrom
How do I mount a file system?
The following command will mount file system /dev/fslv02 on the /test directory:
mount /dev/fslv02 /test
How do I mount all default file systems (all standard file systems in the /etc/filesystems file marked by the mount=true attribute)?
The following command will mount all such file systems:
mount {-a|all}
How do I unmount a file system?
Type the following command to unmount /test file system:
umount /test
How do I display mounted file systems?
Type the following command to display information about all currently mounted file systems:
mount
How do I remove a file system?
Type the following command to remove the /test file system:
rmfs /test
How can I defragment a file system?
The defragfs
command can be used to improve or report the
status of contiguous space within a file system. For example, to defragment
the file system /home, use the following command:
defragfs /home
Which fileset contains a particular binary?
To show bos.acct
contains /usr/bin/vmstat
,
type:
lslpp -w /usr/bin/vmstat
Or to show bos.perf.tools
contains /usr/bin/svmon
,
type:
which_fileset svmon
How do I display information about installed filesets on my system?
Type the following:
lslpp -l
How do I determine if all filesets of maintenance levels are installed on my system?
Type the following:
instfix -i | grep ML
How do I determine if a fix is installed on my system?
To determine if IY24043 is installed, type:
instfix -ik IY24043
How do I install an individual fix by APAR?
To install APAR IY73748 from /dev/cd0
, for example, enter
the command:
instfix -k IY73748 -d /dev/cd0
How do I verify if filesets have required prerequisites and are completely installed?
To show which filesets need to be installed or corrected, type:
lppchk -v
How do I get a dump of the header of the loader section and the symbol entries in symbolic representation?
Type the following:
dump -Htv
How do I determine the amount of paging space allocated and in use?
Type the following:
lsps -a
How do I increase a paging space?
You can use the chps -s
command to dynamically increase
the size of a paging space. For example, if you want to increase the size
of hd6 with 3 logical partitions, you issue the following command:
chps -s 3 hd6
How do I reduce a paging space?
You can use the chps -d
command to dynamically reduce the
size of a paging space. For example, if you want to decrease the size of
hd6 with four logical partitions, you issue the following command:
chps -d 4 hd6
How would I know if my system is capable of using Simultaneous Multi-threading (SMT)?
Your system is capable of SMT if it's a POWER5-based system running AIX 5L Version 5.3.
How would I know if SMT is enabled for my system?
If you run the smtctl
command without any options, it tells
you if it's enabled or not.
Is SMT supported for the 32-bit kernel?
Yes, SMT is supported for both 32-bit and 64-bit kernel.
How do I enable or disable SMT?
You can enable or disable SMT by running the smtctl
command.
The following is the syntax:
smtctl [ -m off | on [ -w boot | now]]
The following options are available:
-m off |
Sets SMT mode to disabled. |
-m on |
Sets SMT mode to enabled. |
-w boot |
Makes the SMT mode change effective on next and subsequent reboots
if you run the bosboot command before the next system
reboot. |
-w now |
Makes the SMT mode change immediately but will not persist across reboot. |
If neither the -w
boot or the -w
now options
are specified, then the mode change is made immediately. It persists across
subsequent reboots if you run the bosboot
command before the
next system reboot.
How do I get partition-specific information and statistics?
The lparstat
command provides a report of partition information
and utilization statistics. This command also provides a display of Hypervisor
information.
Volume groups and logical volumes
How do I know if my volume group is normal, big, or scalable?
Run the lsvg
command on the volume group and look at the
value for MAX PVs. The value is 32 for normal, 128 for big, and 1024 for
scalable volume group.
How to create a volume group?
Use the following command, where s
partition_size
sets the number of megabytes (MB) in each physical partition where the partition_size
is expressed in units of MB from 1 through 1024. (It's 1 through 131072
for AIX 5.3.) The partition_size variable must be equal to a power of 2
(for example: 1, 2, 4, 8). The default value for standard and big volume
groups is the lowest value to remain within the limitation of 1016 physical
partitions per physical volume. The default value for scalable volume groups
is the lowest value to accommodate 2040 physical partitions per physical
volume.
mkvg -y name_of_volume_group -s partition_size list_of_hard_disks
How can I change the characteristics of a volume group?
You use the following command to change the characteristics of a volume group:
chvg
How do I create a logical volume?
Type the following:
mklv -y name_of_logical_volume name_of_volume_group number_of_partition
How do I increase the size of a logical volume?
To increase the size of the logical volume represented by the lv05 directory by three logical partitions, for example, type:
extendlv lv05 3
How do I display all logical volumes that are part of a volume group (for example, rootvg)?
You can display all logical volumes that are part of rootvg by typing the following command:
lsvg -l rootvg
How do I list information about logical volumes?
Run the following command to display information about the logical volume lv1:
lslv lv1
How do I remove a logical volume?
You can remove the logical volume lv7 by running the following command:
rmlv lv7
The rmlv
command removes only the logical volume, but does
not remove other entities, such as file systems or paging spaces that were
using the logical volume.
How do I mirror a logical volume?
How do I remove a copy of a logical volume?
You can use the rmlvcopy
command to remove copies of logical
partitions of a logical volume. To reduce the number of copies of each logical
partition belonging to logical volume testlv, enter:
rmlvcopy testlv 2
Each logical partition in the logical volume now has at most two physical partitions.
Queries about volume groups
To show volume groups in the system, type:
lsvg
To show all the characteristics of rootvg
, type:
lsvg rootvg
To show disks used by rootvg
, type:
lsvg -p rootvg
How to add a disk to a volume group?
Type the following:
extendvg VolumeGroupName hdisk0 hdisk1 ... hdiskn
How do I find out what the maximum supported logical track group (LTG) size of my hard disk?
You can use the lquerypv
command with the -M
flag. The output gives the LTG size in KB. For instance, the LTG size for
hdisk0 in the following example is 256 KB.
/usr/sbin/lquerypv -M hdisk0 256
You can also run the lspv
command on the hard disk and look
at the value for MAX REQUEST.
What does syncvg
command do?
The syncvg
command is used to synchronize stale physical
partitions. It accepts names of logical volumes, physical volumes, or volume
groups as parameters.
For example, to synchronize the physical partitions located on physical volumes hdisk6 and hdisk7, use:
syncvg -p hdisk4 hdisk5
To synchronize all physical partitions from volume group testvg, use:
syncvg -v testvg
How do I replace a disk?
extendvg
VolumeGroupName hdisk_new
migratepv
hdisk_bad hdisk_new reducevg -d
VolumeGroupName hdisk_bad
How can I clone (make a copy of ) the rootvg?
You can run the alt_disk_copy
command to copy the current
rootvg to an alternate disk. The following example shows how to clone the
rootvg to hdisk1.
alt_disk_copy -d hdisk1
How can I display or set values for network parameters?
The no
command sets or displays current or next boot values
for network tuning parameters.
How do I get the IP address of my machine?
Type one of the following:
ifconfig -a host Fully_Qualified_Host_Name
For example, type host cyclop.austin.ibm.com.
AIX commands you should not leave home without
IBM eServer™ pSeries® and AIX Information Center: This site provides the latest documentation on AIX.
The AIX and UNIX developerWorks zone provides a wealth of information relating to all aspects of AIX systems administration and expanding your UNIX skills.
developerWorks technical events and webcasts: Stay current with developerWorks technical events and webcasts. AIX 5L Wiki: Visit this collaborative environment for technical information related to AIX.
Podcasts: Tune
in and catch up with IBM technical experts.
Society
Groupthink : Two Party System as Polyarchy : Corruption of Regulators : Bureaucracies : Understanding Micromanagers and Control Freaks : Toxic Managers : Harvard Mafia : Diplomatic Communication : Surviving a Bad Performance Review : Insufficient Retirement Funds as Immanent Problem of Neoliberal Regime : PseudoScience : Who Rules America : Neoliberalism : The Iron Law of Oligarchy : Libertarian Philosophy
Quotes
War and Peace : Skeptical Finance : John Kenneth Galbraith :Talleyrand : Oscar Wilde : Otto Von Bismarck : Keynes : George Carlin : Skeptics : Propaganda : SE quotes : Language Design and Programming Quotes : Random IT-related quotes : Somerset Maugham : Marcus Aurelius : Kurt Vonnegut : Eric Hoffer : Winston Churchill : Napoleon Bonaparte : Ambrose Bierce : Bernard Shaw : Mark Twain Quotes
Bulletin:
Vol 25, No.12 (December, 2013) Rational Fools vs. Efficient Crooks The efficient markets hypothesis : Political Skeptic Bulletin, 2013 : Unemployment Bulletin, 2010 : Vol 23, No.10 (October, 2011) An observation about corporate security departments : Slightly Skeptical Euromaydan Chronicles, June 2014 : Greenspan legacy bulletin, 2008 : Vol 25, No.10 (October, 2013) Cryptolocker Trojan (Win32/Crilock.A) : Vol 25, No.08 (August, 2013) Cloud providers as intelligence collection hubs : Financial Humor Bulletin, 2010 : Inequality Bulletin, 2009 : Financial Humor Bulletin, 2008 : Copyleft Problems Bulletin, 2004 : Financial Humor Bulletin, 2011 : Energy Bulletin, 2010 : Malware Protection Bulletin, 2010 : Vol 26, No.1 (January, 2013) Object-Oriented Cult : Political Skeptic Bulletin, 2011 : Vol 23, No.11 (November, 2011) Softpanorama classification of sysadmin horror stories : Vol 25, No.05 (May, 2013) Corporate bullshit as a communication method : Vol 25, No.06 (June, 2013) A Note on the Relationship of Brooks Law and Conway Law
History:
Fifty glorious years (1950-2000): the triumph of the US computer engineering : Donald Knuth : TAoCP and its Influence of Computer Science : Richard Stallman : Linus Torvalds : Larry Wall : John K. Ousterhout : CTSS : Multix OS Unix History : Unix shell history : VI editor : History of pipes concept : Solaris : MS DOS : Programming Languages History : PL/1 : Simula 67 : C : History of GCC development : Scripting Languages : Perl history : OS History : Mail : DNS : SSH : CPU Instruction Sets : SPARC systems 1987-2006 : Norton Commander : Norton Utilities : Norton Ghost : Frontpage history : Malware Defense History : GNU Screen : OSS early history
Classic books:
The Peter Principle : Parkinson Law : 1984 : The Mythical Man-Month : How to Solve It by George Polya : The Art of Computer Programming : The Elements of Programming Style : The Unix Hater’s Handbook : The Jargon file : The True Believer : Programming Pearls : The Good Soldier Svejk : The Power Elite
Most popular humor pages:
Manifest of the Softpanorama IT Slacker Society : Ten Commandments of the IT Slackers Society : Computer Humor Collection : BSD Logo Story : The Cuckoo's Egg : IT Slang : C++ Humor : ARE YOU A BBS ADDICT? : The Perl Purity Test : Object oriented programmers of all nations : Financial Humor : Financial Humor Bulletin, 2008 : Financial Humor Bulletin, 2010 : The Most Comprehensive Collection of Editor-related Humor : Programming Language Humor : Goldman Sachs related humor : Greenspan humor : C Humor : Scripting Humor : Real Programmers Humor : Web Humor : GPL-related Humor : OFM Humor : Politically Incorrect Humor : IDS Humor : "Linux Sucks" Humor : Russian Musical Humor : Best Russian Programmer Humor : Microsoft plans to buy Catholic Church : Richard Stallman Related Humor : Admin Humor : Perl-related Humor : Linus Torvalds Related humor : PseudoScience Related Humor : Networking Humor : Shell Humor : Financial Humor Bulletin, 2011 : Financial Humor Bulletin, 2012 : Financial Humor Bulletin, 2013 : Java Humor : Software Engineering Humor : Sun Solaris Related Humor : Education Humor : IBM Humor : Assembler-related Humor : VIM Humor : Computer Viruses Humor : Bright tomorrow is rescheduled to a day after tomorrow : Classic Computer Humor
The Last but not Least Technology is dominated by two types of people: those who understand what they do not manage and those who manage what they do not understand ~Archibald Putt. Ph.D
Copyright © 1996-2021 by Softpanorama Society. www.softpanorama.org was initially created as a service to the (now defunct) UN Sustainable Development Networking Programme (SDNP) without any remuneration. This document is an industrial compilation designed and created exclusively for educational use and is distributed under the Softpanorama Content License. Original materials copyright belong to respective owners. Quotes are made for educational purposes only in compliance with the fair use doctrine.
FAIR USE NOTICE This site contains copyrighted material the use of which has not always been specifically authorized by the copyright owner. We are making such material available to advance understanding of computer science, IT technology, economic, scientific, and social issues. We believe this constitutes a 'fair use' of any such copyrighted material as provided by section 107 of the US Copyright Law according to which such material can be distributed without profit exclusively for research and educational purposes.
This is a Spartan WHYFF (We Help You For Free) site written by people for whom English is not a native language. Grammar and spelling errors should be expected. The site contain some broken links as it develops like a living tree...
|
You can use PayPal to to buy a cup of coffee for authors of this site |
Disclaimer:
The statements, views and opinions presented on this web page are those of the author (or referenced source) and are not endorsed by, nor do they necessarily reflect, the opinions of the Softpanorama society. We do not warrant the correctness of the information provided or its fitness for any purpose. The site uses AdSense so you need to be aware of Google privacy policy. You you do not want to be tracked by Google please disable Javascript for this site. This site is perfectly usable without Javascript.
Last modified: March 12, 2019